Clock and date setting - 5th Gen Subaru Impreza Forum
 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 02-23-2017, 03:36 PM Thread Starter
Junior Member
 
DTPI1's Avatar
 
Join Date: Feb 2017
Location: Sydney, Australia
Posts: 2
Question Clock and date setting

Last Friday I picked up my new Subaru (2017 2.0S) sedan form the dealer. I noticed after I had taken it home that the time and date were not set correctly for my location.
I read the manual and noticed there was a GPS synch setting. This should set the time in relation to the location of the car I would have though.
The next day I took the car back to the dealer and was shown how to manually set the time and date. All seemed to be going well until today, the time and date seems to have reset it self to an incorrect time and date.
Has anyone else experienced this? What if anything was done to correct this issue.
Appreciate any help / advise.
First time user of this forum.
regards
Tony
DTPI1 is offline  
post #2 of 10 (permalink) Old 02-25-2017, 08:30 AM
Member
 
Join Date: Feb 2017
Posts: 34
yep! I had that too.

Currently i'm running on "Auto" time set. It didn't work at first but the next day the day was displaying the correct time. i have no idea why.

That said, the Navigation system still has the wrong time even though the other clock is correct. The dealer didn't know how to fix it and just told me to wait for a software update...
Bazza is online now  
post #3 of 10 (permalink) Old 02-27-2017, 03:35 PM Thread Starter
Junior Member
 
DTPI1's Avatar
 
Join Date: Feb 2017
Location: Sydney, Australia
Posts: 2
Thanks Bazza.
It did it again today. Time went back to zero and date also changed.
I noticed also that some features, like the side mirror warnings you get when a car is passing you or the warning you get when crossing a lane without indicating, were also not working this morning.
The navigation system also displays wrong information about ETA.
I have booked the car for first month check up and will try and get some answers then..
Regards
Tony
DTPI1 is offline  
 
post #4 of 10 (permalink) Old 02-27-2017, 05:41 PM
Junior Member
 
Join Date: Jan 2017
Posts: 7
Garage
Hanging on to 49

My clock reset driving from dealership. Since then it randomly resets after I manually fix it. I am ok with it being Thursday, 12am 6 degrees forever if it means I don't actually get any older. I knew there were issues and I bought it anyway...software better fix it or I will be getting another civic.
Imprez240 is offline  
post #5 of 10 (permalink) Old 03-01-2017, 04:23 PM
Junior Member
 
Join Date: Mar 2017
Posts: 3
Here's more, from another web forum:

(I have the clock problem described below on my 2017 Impreza Premium hatchback)

Here's the text from the bulletin WTN-74:

"Although the main purpose for this campaign is to address operational concerns involving the rear view camera feature, software is also included in this update for the following other conditions:

1) After switching the vehicle (ACC or IGN) on, the display screen goes black with no audio output and the hard key buttons are illuminated (on solid, or ashing / blinking).

2) Time of day displayed in the MFD (Multi-Function Display) is incorrect and the arrival time displayed in Navigation units is also incorrect.

3) The time in the MFD automatically reverts back to a “default” setting, even after setting the time using “Manual” mode.

4) Audio volume goes to maximum automatically after one click of the volume up button on the steering wheel. In some cases, this condition may also occur without input from the operator. Maximum volume is also displayed on the screen."
PennPat is offline  
post #6 of 10 (permalink) Old 03-06-2017, 07:02 PM
Junior Member
 
Join Date: Mar 2017
Posts: 1
Our 2017 Impreza also has the clock problem: When on auto, it resets to a random time rather than correctly resetting to the time on the bluetooth-connected phone. When on manual and after it is reset to the correct time, it stays at the correct time but then once every few days it resets itself to a random time.
maria is offline  
post #7 of 10 (permalink) Old 03-21-2017, 07:27 PM
Member
 
Join Date: Feb 2017
Posts: 34
Sigh!

I have all the current updates including the recall but now i have a new clock problem.

On startup the clock displays a random time and never changes. It's stuck. This impacts the MFD and the Nav system. They are both in sync but stuck.
Bazza is online now  
post #8 of 10 (permalink) Old 03-23-2017, 05:05 AM
Member
 
Join Date: Feb 2017
Posts: 34
I caught this again today - When the clock was wrong the navigation was stuck on "Navigation is loading" for the entire journey. It never recovered.
Bazza is online now  
post #9 of 10 (permalink) Old 03-23-2017, 08:32 AM
Member
 
Scooby's Avatar
 
Join Date: Jan 2017
Location: Brighton Ont. Canada
Posts: 81
Quote:
Originally Posted by maria View Post
Our 2017 Impreza also has the clock problem: When on auto, it resets to a random time rather than correctly resetting to the time on the bluetooth-connected phone. When on manual and after it is reset to the correct time, it stays at the correct time but then once every few days it resets itself to a random time.
Since I have the impreza preminum the clock I adjusted once(time change)
Manual Mode.
Set the time and date etc go to (set)
Okay the (set) and it should say (set completed)
Then go to the( back button) and exit.
That's how I set mine.
I have started the car enough times and it has not given any problems.
Hope this helps.
Scooby is online now  
post #10 of 10 (permalink) Old 03-28-2017, 11:39 AM
Junior Member
 
Join Date: Mar 2017
Posts: 22
I don't remember if I read this here, but I saw that the auto clock function relies on the bluetooth connection to your phone. However, on my iPhone I also have to enable "Show Notifications" for it to sync time. When it was off before, the clock hour and minute were always wrong.

To enable "Show Notifications" on an iPhone: Settings > Bluetooth > Subaru BT (tap on the "I" icon) > Enable "Show Notifications"
starbot is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 


Content Relevant URLs by vBSEO 3.6.1