WUA86: HK Reprogram - Page 8 - 5th Gen Subaru Impreza Forum
 21Likes
Reply
 
LinkBack Thread Tools
post #71 of 79 (permalink) Old 03-08-2019, 10:06 PM
Senior Member
 
AstroKats's Avatar
 
Join Date: Dec 2018
Location: Santa Monica, CA
Posts: 138
Quote:
Originally Posted by BruceP View Post
What is this world coming to when an automaker can be SUED because the radio has some odd behavior?... sounds like some lawyers are making a mountain out of a molehill

Heck, I rarely even turn my Impreza radio on. I leave the volume down and screen blank 90% of the time. When I do turn it on, it plays the music from my USB just fine. (I do dislike the "boomy" bass and lexicographical ordering of the songs.... but this 'fix' does not address either of these issues.)


I own Subaru because of the legendary AWD in the snow.... not for the radio.
I'm not a fan of those kinds of lawyers either, and I don't think they will get anywhere. How much pain and suffering can there possibly be from losing a radio preset?

Kudos to Subaru, though...

'18 Crosstrek Limited, DGM, with HK/nav package
AstroKats is offline  
post #72 of 79 (permalink) Old 03-09-2019, 12:10 PM
Junior Member
 
Join Date: Mar 2019
Posts: 1
Just got mine done yesterday in my 2017. Wish I didn’t. Twice on my commute home last night the radio just cut off and no sound at all. Thru car radio, through CarPlay on my iPhone using Bandcamp, Apple Music or Spotify, all of which worked fine before. Popped back on out of the blue about 5-7 minutes later. WTF?
rich815 is offline  
post #73 of 79 (permalink) Old 03-09-2019, 08:06 PM Thread Starter
Super Moderator
 
coletrain's Avatar
 
Join Date: Apr 2017
Location: Chester County, Pennsylvania
Posts: 724
Garage
We got the '18 Crosstrek completed today. Al though we weren't having any issues.

While using the '17 Impreza today I decided to try playing music through my iPhone while using maps for navigation. After the second song CarPlay just scrolled through all my songs, not playing a single song. Maps worked flawlessly. I'll try it again tomorrow morning.

Subaru Ambassador

'17 LRP Impreza Sport 5dr CVT
'18 CGK Crosstrek Premium CVT
coletrain is offline  
 
post #74 of 79 (permalink) Old 03-19-2019, 06:11 PM
Junior Member
 
CAP LOCK KID's Avatar
 
Join Date: May 2018
Location: Ontario, Canada
Posts: 24
Had it done on the '18 Impreza today... see if the Android Auto is any better. Extremely slow to load.

If it's better, i'll take the Trek in.

Marty
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


18 Impreza Sport-Tech w/ Eyesight
CAP LOCK KID is online now  
post #75 of 79 (permalink) Old 03-19-2019, 06:12 PM
Senior Member
 
AstroKats's Avatar
 
Join Date: Dec 2018
Location: Santa Monica, CA
Posts: 138
Quote:
Originally Posted by CAP LOCK KID View Post
Had it done on the '18 Impreza today... see if the Android Auto is any better. Extremely slow to load.

If it's better, i'll take the Trek in.
Do you know what versions you had before in the cars?

'18 Crosstrek Limited, DGM, with HK/nav package
AstroKats is offline  
post #76 of 79 (permalink) Old 03-21-2019, 08:47 PM
Junior Member
 
CAP LOCK KID's Avatar
 
Join Date: May 2018
Location: Ontario, Canada
Posts: 24
Quote:
Originally Posted by AstroKats View Post
Do you know what versions you had before in the cars?
Sorry, don't know what was in the Impreza. I can check the Trek when the wife gets home.
AstroKats likes this.

Marty
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


18 Impreza Sport-Tech w/ Eyesight
CAP LOCK KID is online now  
post #77 of 79 (permalink) Old Yesterday, 02:05 AM
Junior Member
 
splyssr's Avatar
 
Join Date: Nov 2018
Location: Northern CA
Posts: 23
I got the update via recall notice, appointment made, radio fried during update. Drove around with a bricked unit for 9 days. On the 10th day, I got a courtesy car. Next day? Car is done. bla bla bla ....I'm bitter.

The newly replaced unit was great, then one day(a week later) it just dropped custom shortcuts. no left/right screens, no ADD SHORTCUT icon. However, it retained all presets, contacts, and bluetooth connectivity.

I dicked around with settings, but finally just did a factory reset. All back to normal, moveable icons, doing fine.
Two days later, back to the 5 icon HOME screen. No custom shortcuts, no slide screen.

WTF

I wish I never did the recall.
Attached Thumbnails
Click image for larger version

Name:	20190416_003413.jpg
Views:	19
Size:	103.0 KB
ID:	20760   Click image for larger version

Name:	20190416_003326.jpg
Views:	15
Size:	69.1 KB
ID:	20762  

Last edited by splyssr; Yesterday at 02:13 AM.
splyssr is online now  
post #78 of 79 (permalink) Old Yesterday, 11:33 AM
Senior Member
 
DeanGibson's Avatar
 
Join Date: Aug 2017
Location: Seattle, WA
Posts: 167
Garage
Lightbulb There's an option for that ...

Quote:
Originally Posted by splyssr View Post
...

The newly replaced unit was great, then one day(a week later) it just dropped custom shortcuts. no left/right screens, no ADD SHORTCUT icon. However, it retained all presets, contacts, and bluetooth connectivity.

...
This happens because "enable shortcuts" gets turned off (happens to me occasionally). Turn it back on in settings, & all of the above appears as before (nothing lost).

2017 Impreza 2.0i AWD 5MT 4DR sedan

  • To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
  • Exterior: Venetian Red Pearl
  • Interior: Ivory White Pearl
Prior (auto): 1960 Corvair, 1965 Mustang, 1978 Olds (diesel)
Prior (5MT): 1980 & 1991 Celicas, 1998 Audi A4 Quattro

Please do not ask me private questions of public interest -- that is what forums are for!
DeanGibson is offline  
post #79 of 79 (permalink) Old Yesterday, 11:41 PM
Junior Member
 
splyssr's Avatar
 
Join Date: Nov 2018
Location: Northern CA
Posts: 23
Quote:
Originally Posted by DeanGibson View Post
This happens because "enable shortcuts" gets turned off (happens to me occasionally). Turn it back on in settings, & all of the above appears as before (nothing lost).
That was my problem. Thank you. All better now.
splyssr is online now  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
ECM Reprogram for Low Speed Stall skinny2 5th Gen Impreza Recalls & Service Bulletins 1 09-06-2018 04:34 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome