5th Gen Subaru Impreza Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 2017 Subaru Impreza and the issue has been going on for a few weeks. Any time I come to a complete stop and I step on the gas to go sometimes the car will start off going then it pauses the RPM's Drop it almost dies sometimes, then it will like catch up and RPM's will shoot up. I am at a lose as to what could be causing this. I thought it was a issues with CVT but it only happens from a stop to a start the rest of the drive after you get past the initial hesitation is just fine. So far I changed out spark plugs, new air filter, cleaned MAF sensor, put in some Seafoam in the tank thinking it was clogged injectors. The no check engine light is not on so no codes to pull.

Has anyone came across this issue before or know what I should be checking. Here are 2 videos of what its like when coming from a stop.



Sorry about the sound please have it turned down
 

·
Registered
2018 Impreza Limited
Joined
·
137 Posts
Have you connected to a scan tool and scanned all of the sub systems? I have several nagging codes about my entertainment system for example (not sure what it is as I don't notice any problems) but no check engine light. You don't need a check engine to have a cvt error code. Only warning light on the dash about the CVT is the AT Fluid Overheat warning.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
No I havent scanned what should I be looking for? anything in particular, I hate the fact that all of the fuel components are in the tank seems like a real pain to change out. I want to start looking at Fuel delivery after I check everything Air related. Next up will be O2 sensors, Cat Throttle body was cleaned already
 

·
Registered
2018 Impreza Limited
Joined
·
137 Posts
I don't know what scan tool you have, but my Autel has the ability to scan for the vin, from there, it looks up the systems the car may have, and then checks if it finds those systems one by one. If it finds it, it checks the system for error codes.
 

·
Registered
Joined
·
4 Posts
I have a 2017 Subaru Impreza and the issue has been going on for a few weeks. Any time I come to a complete stop and I step on the gas to go sometimes the car will start off going then it pauses the RPM's Drop it almost dies sometimes, then it will like catch up and RPM's will shoot up. I am at a lose as to what could be causing this. I thought it was a issues with CVT but it only happens from a stop to a start the rest of the drive after you get past the initial hesitation is just fine. So far I changed out spark plugs, new air filter, cleaned MAF sensor, put in some Seafoam in the tank thinking it was clogged injectors. The no check engine light is not on so no codes to pull.

Has anyone came across this issue before or know what I should be checking. Here are 2 videos of what its like when coming from a stop.



Sorry about the sound please have it turned down
i was reading about this issue earlier over on nasioc, and the first thing that came to mind was the intake. installing pretty much any mod that alters the intake resonator and/or stock intake setup will make your MAF readings go ballistic, resulting in pretty much the same issue youre having. have you altered your intake system at all?
 

·
Registered
2.0i 5D 5MT Silver
Joined
·
196 Posts
Honestly, seems like a CVT issue but I may be completely wrong. I'd ask the dealer and see if they can at least point you in the right direction.
 
1 - 10 of 10 Posts
Top