5th Gen Subaru Impreza Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
every time I turn on my car (impreza hatchback premium), I always need to browse my music folder... this seems inconvenient. advise please. thanks.
 

·
Premium Member
2017 Mazda CX-5 Sport
Joined
·
2,186 Posts
If I just hit play it works fine. If you are seeing all of the folders maybe it is the way you have the music set up on your usb?

Don't use folders, just have them all in one playlist.
 

·
Registered
Joined
·
117 Posts
I have my music in multiple folders and the car just organizes them all alphabetically. My music starts playing the second I start my car, which can be a bit of a shock if I pull up to the house with it playing loud and forget to turn it down lol. The only issue sometimes is when I put a new USB in it has to "index" and if there is a lot of songs on there it takes a WHILE!
 

·
Registered
Joined
·
220 Posts
I have mine set to play off the USB when the car is started. So far, so good
 

·
Registered
Joined
·
2 Posts
Is there a setting you guys are using? Because for me, when I turn the car on I see a message "loading media" but it never loads. Hitting play does nothing. I actually have to unplug and plug in the usb stick every time i turn the car on. Its so annoying and inconvenient.
 

·
Registered
Joined
·
68 Posts
Is there a setting you guys are using? Because for me, when I turn the car on I see a message "loading media" but it never loads. Hitting play does nothing. I actually have to unplug and plug in the usb stick every time i turn the car on. Its so annoying and inconvenient.
As others have stated

Turn off USB Auto Play. When the car is stated the radio will come on an then push the Media button. It should start with song you left off with. Also make sure the software is up to date. I always leave my thumb drive plugged in and have no problems.
 

·
Registered
Joined
·
68 Posts
As others have stated

Turn off USB Auto Play. When the car is stated the radio will come on an then push the Media button. It should start with song you left off with. Also make sure the software is up to date. I always leave my thumb drive plugged in and have no problems.
When the car is started
 

·
Registered
Joined
·
177 Posts
Using a USB hub?

Is there a setting you guys are using? Because for me, when I turn the car on I see a message "loading media" but it never loads. Hitting play does nothing. I actually have to unplug and plug in the usb stick every time i turn the car on. Its so annoying and inconvenient.
Are you using a hub? I am, and that's what I have to do. If I don't use the hub, it works fine.
 

·
Registered
Joined
·
177 Posts
Correction

Are you using a hub? I am, and that's what I have to do. If I don't use the hub, it works fine.
Update: If I don't use the hub, it now doesn't work.

There's something I've done that allows the car to start & then play the already-inserted USB stick on a cold start, but I haven't yet figured out what it is. I think it works on a warm start (vehicle "off" for less than 3 minutes), but need to verify.

Subaru saying it's a heat issue to not keep the USB stick inserted, is BS.
 

·
Registered
Joined
·
4 Posts
Update: If I don't use the hub, it now doesn't work.

There's something I've done that allows the car to start & then play the already-inserted USB stick on a cold start, but I haven't yet figured out what it is. I think it works on a warm start (vehicle "off" for less than 3 minutes), but need to verify.

Subaru saying it's a heat issue to not keep the USB stick inserted, is BS.
I have the same issue with or without a hub. Before I turn the car off I switch to radio mode, and about 90% of the time once I switch over to usb it will play no problem. The other 10% it will say loading and never load, and I have to unplug and plug in the usb to get it to work. Would be nice to figure out a solution to this as it's extremely annoying.
 

·
Registered
Joined
·
45 Posts
I have the Carplay app so I don't know if you can do this without it. Using the USB with an iPhone, I just hit the phone talk button and tell Siri what music I want to hear. Also great for navigation using the phone.
 

·
Registered
Joined
·
177 Posts
Sticky tape solution

I have solved this issue of not playing an already-inserted USB stick when the vehicle starts, but it isn't going to please most people:

I mounted (w/ dual-sided sticky tape) in the center console, a 7-port USB hub ("Vanoss") with dual host inputs. Each of the 7 USB output ports has a push-button switch, to switch between the either of the two inputs. In effect, an on/off switch for each output port.

The problem is probably that when the head unit software boots, it probably mounts any USB sticks that it finds, in order to do a firmware update if one is present on the USB stick. It probably mounts the USB stick with "root"/"admin" privileges. If so, that means that when the media player is started, it can see the files on the USB stick but not be able to open them. If a USB stick is inserted (or re-inserted) later, it is probably mounted with normal user privileges, and thus the files are readable.
 
  • Like
Reactions: bonkewl53

·
Registered
Joined
·
177 Posts
Needless complexity is the order of the day ...

I have solved this issue of not playing an already-inserted USB stick when the vehicle starts, but it isn't going to please most people ...
As I reported elsewhere here, I have a mini stereo plug inserted into the "AUX" jack, so that I can select AUX to silence the radio without turning the volume all the way down.

So, here's how I operate with a USB stick with music:
  1. Before I exit the car, I switch from USB music to AUX. That SILENCES the head unit.
  2. When I later re-enter & start the car, AUX is still selected.
  3. I press the button on my USB hub (as described in my prior message) to DESELECT and then RESELECT the USB stick (effectively the same as removing the USB stick & reinserting it).
  4. I then switch (on the head unit) from AUX to USB.
  5. The head unit switches to USB & shows the current track (& album or playlist number).
  6. I press play, & the head unit resumes play at the point it was at, when I switched away from USB to AUX in step #1 above.

This is a lot better than having the radio blare at you, while you try to resume playing the USB stick where you left off. It also appears to be more reliable.

The fact that we have to jump through such hoops is ridiculous (see my related thread on incompetent software developers).
 

·
Registered
Joined
·
1 Posts
USB Music message"Media is Loading" does not play

Is there a setting you guys are using? Because for me, when I turn the car on I see a message "loading media" but it never loads. Hitting play does nothing. I actually have to unplug and plug in the usb stick every time i turn the car on. Its so annoying and inconvenient.
I experienced the same problem.. I called my Subaru Dealership's/Delivery specialist guy about this problem. He said as of December 10 2017 they now have a Starlink software upgrade to fix this and other Audio issues, including songs that stop playing mid way through,screen freeze,and iphone music issues. he scheduled me to come in on January 6, 2018 to load the software... I will let you know how this turns out
 

·
Registered
Joined
·
177 Posts
Old habits die hard

In recent experiments, I have found that if you turn the ignition on & wait a couple of seconds before starting the engine, the probability is much higher that the USB stick will play music.

The problem is, this goes against 50+ years of my habit in starting a vehicle engine of inserting the key and going immediately to cranking the engine.
 
1 - 20 of 21 Posts
Top