5th Gen Subaru Impreza Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey all, I recently bought a 2019 impreza premium hatch [one week ago]. Whenever I cold start my car, it idles at around 2k rpm and indicates the coolant temp is low. After about 5 minutes, the idle drops down to normal range and the indicator goes away. I usually wait until this happens before I hit the road. I just want to make sure there isnt anything inherently wrong with my car, or whether or not I should change how I'm doing things.
 

·
Registered
Joined
·
866 Posts
 

·
ModFather
2019 Subaru Impreza Sport 5 Dr. Manual Shift
Joined
·
1,131 Posts
It's okay to drive when the blue light is on. Just drive the car as you normally would, don't start flooring it and driving like a crazy person. I wouldn't shift at red line etc. Give the motor time to get everything warm which depending on ambient temp takes 10 -5 minutes of driving. Then feel free to drive like a crazy person :) (or not) Just letting the car sit and idle before the light goes out just wastes gas.
 
  • Like
Reactions: Byll

·
Registered
2018 Impreza base. 5MT
Joined
·
39 Posts
I hooked my scan tool up one morning, blue coolant light goes out around 105 degrees Fahrenheit, if memory serves me correctly.
 

·
Registered
Joined
·
79 Posts
On the 2019 Impreza base hatch I drive...the temp light goes out at 121⁰ like clock work.

As peaty says...ok to drive...just nurse it until temp is reached...plus it doesn't hurt to let the cvt temp get up a little as well which takes a bit longer than the coolant.
 
1 - 5 of 5 Posts
Top