5th Gen Subaru Impreza Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Last Friday I picked up my new Subaru (2017 2.0S) sedan form the dealer. I noticed after I had taken it home that the time and date were not set correctly for my location.
I read the manual and noticed there was a GPS synch setting. This should set the time in relation to the location of the car I would have though.
The next day I took the car back to the dealer and was shown how to manually set the time and date. All seemed to be going well until today, the time and date seems to have reset it self to an incorrect time and date.
Has anyone else experienced this? What if anything was done to correct this issue.
Appreciate any help / advise.
First time user of this forum. 0:)
regards
Tony
 

·
Registered
Joined
·
46 Posts
yep! I had that too.

Currently i'm running on "Auto" time set. It didn't work at first but the next day the day was displaying the correct time. i have no idea why. :)

That said, the Navigation system still has the wrong time even though the other clock is correct. The dealer didn't know how to fix it and just told me to wait for a software update...
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks Bazza.
It did it again today. Time went back to zero and date also changed.
I noticed also that some features, like the side mirror warnings you get when a car is passing you or the warning you get when crossing a lane without indicating, were also not working this morning.
The navigation system also displays wrong information about ETA.
I have booked the car for first month check up and will try and get some answers then..
Regards
Tony
 

·
Registered
Joined
·
7 Posts
Hanging on to 49

My clock reset driving from dealership. Since then it randomly resets after I manually fix it. I am ok with it being Thursday, 12am 6 degrees forever if it means I don't actually get any older. I knew there were issues and I bought it anyway...software better fix it or I will be getting another civic.
 

·
Registered
Joined
·
3 Posts
Here's more, from another web forum:

(I have the clock problem described below on my 2017 Impreza Premium hatchback)

Here's the text from the bulletin WTN-74:

"Although the main purpose for this campaign is to address operational concerns involving the rear view camera feature, software is also included in this update for the following other conditions:

1) After switching the vehicle (ACC or IGN) on, the display screen goes black with no audio output and the hard key buttons are illuminated (on solid, or ashing / blinking).

2) Time of day displayed in the MFD (Multi-Function Display) is incorrect and the arrival time displayed in Navigation units is also incorrect.

3) The time in the MFD automatically reverts back to a “default” setting, even after setting the time using “Manual” mode.

4) Audio volume goes to maximum automatically after one click of the volume up button on the steering wheel. In some cases, this condition may also occur without input from the operator. Maximum volume is also displayed on the screen."
 

·
Registered
Joined
·
1 Posts
Our 2017 Impreza also has the clock problem: When on auto, it resets to a random time rather than correctly resetting to the time on the bluetooth-connected phone. When on manual and after it is reset to the correct time, it stays at the correct time but then once every few days it resets itself to a random time.
 

·
Registered
Joined
·
46 Posts
Sigh!

I have all the current updates including the recall but now i have a new clock problem.

On startup the clock displays a random time and never changes. It's stuck. This impacts the MFD and the Nav system. They are both in sync but stuck.
 

·
Registered
Joined
·
46 Posts
I caught this again today - When the clock was wrong the navigation was stuck on "Navigation is loading" for the entire journey. It never recovered.
 

·
Registered
Joined
·
200 Posts
Our 2017 Impreza also has the clock problem: When on auto, it resets to a random time rather than correctly resetting to the time on the bluetooth-connected phone. When on manual and after it is reset to the correct time, it stays at the correct time but then once every few days it resets itself to a random time.
Since I have the impreza preminum the clock I adjusted once(time change)
Manual Mode.
Set the time and date etc go to (set)
Okay the (set) and it should say (set completed)
Then go to the( back button) and exit.
That's how I set mine.
I have started the car enough times and it has not given any problems.
Hope this helps.
 

·
Registered
Joined
·
25 Posts
I don't remember if I read this here, but I saw that the auto clock function relies on the bluetooth connection to your phone. However, on my iPhone I also have to enable "Show Notifications" for it to sync time. When it was off before, the clock hour and minute were always wrong.

To enable "Show Notifications" on an iPhone: Settings > Bluetooth > Subaru BT (tap on the "I" icon) > Enable "Show Notifications"
 
1 - 10 of 10 Posts
Top