5th Gen Subaru Impreza Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
Anyone have this happen to them? I don't use the ebrake often at all, but there is a small tear in the leather (or whatever the material is). When you pull the ebrake up you can see that it's pulling against it. I'll get some pics up later today. Wonder if warranty covers that.
 

·
Registered
Joined
·
308 Posts
That's going to be a tough one.. I think it'll depend on how nice your dealership is considering they'll probably think you tore it somehow. Worth a try though!
 

·
Registered
Joined
·
46 Posts
Discussion Starter #4
i also noticed that when it snags the ebrake boot lock that, the lever doesn't go all the way up... explains why I thought the ebrake sucked! I'm making an appointment for a week from now. Wish me Luck!
 

·
Registered
Joined
·
63 Posts
Intrigued, I check mine out good, fully pulled and released. Felt it up and down and there is nothing that would cause a tear like that, not even close. Warranty should cover that for sure.
 

·
Registered
Joined
·
41 Posts
This also happened to me. I noticed it earlier last week. I'm going in for my 6k mile service soon and am going to speak to them about this too. You're saying that your dealer ended up covering this under the warranty? Seems like a factory error issue to me
 

·
Registered
Joined
·
320 Posts
Mine has also torn, it's a small tear on the side away from the driver maybe an inch back from the front of the boot, so it's not like something sticking out of my pocket jabbed it. it almost looks more like a puncture but I'm pretty certain it isn't, especially since the edges don't look pushed in.

I'm at about 8300 miles and I noticed it somewhere in the last 500 miles.

I felt around with the ebrake engaged and disengaged and didn't notice anything that seemed obvious that might was worn it through. I couldn't think of any other explanation as I've not hit it with anything or placed anything hard & sharp near it.
 

·
Registered
Joined
·
23 Posts
Had my appointment yesterday. They fixed the 2 recalls, and they ordered an ebrake boot under warranty.
I use my ebrake regularly (parking on inclines/declines, power slides, back flips, etc.) and my boot tore in that spot probably within 6 months of having the vehicle although about a year after it started it is still pretty small and not as large as your tear. You're right that the boot stretches too tightly over that piece of metal and that is absolutely doing it. I keep forgetting to mention it when I go in to the dealer so I'm glad to hear they will replace it (of course just for it to tear again...).
 

·
Registered
Joined
·
260 Posts
Anyone have this happen to them? I don't use the ebrake often at all, but there is a small tear in the leather (or whatever the material is). When you pull the ebrake up you can see that it's pulling against it. I'll get some pics up later today. Wonder if warranty covers that.
same happened to me as well.
 

·
Registered
Joined
·
295 Posts
Mine has done this too. I will engage my dealership and see what they say
 

·
Registered
Joined
·
469 Posts
Sounds like an issue that a lot of folks are encountering. Anyone contact SoA yet about getting a real fix in the works, since it sounds like just replacing the boot isn't going to solve the issue of the protruding metal bit?
 

·
Registered
Joined
·
41 Posts
Yup, I noticed this on my '17 a while back. It feels like the boot covering the ebrake apparatus was just designed too tightly. I just figured I'd order an aftermarket one if I keep the car post-warranty.
 
1 - 15 of 15 Posts
Top