5th Gen Subaru Impreza Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi everyone.
have had 4 Subarus myself (LGT, Crosstrek, now on my second Forester a 21 sport)

recently picked my son up a 2018 Impreza Sport. Havedone some minor things like Tint, roof wrap, weather tech mats, Beamtech LED low beams.
Any other suggestions on beginner mods?
Wheel Tire Vehicle Car Hood
 

·
Registered
Joined
·
38 Posts
If he will be using Android Auto or CarPlay a good idea to get a USB powered data hub with quick charging so the phone actually charges instead of losing battery while plugged in. Not fun having your phone die and GPS disappear while it's leading you somewhere you're not familiar with. Rain guards are also nice to have. A tad bit more involved, but I'd highly recommend the steering lockdown mod if he will do any highway driving, keeps the car from wandering so much

That roof wrap looks good, might have to do that soon myself
 

·
Registered
Joined
·
189 Posts
FWIW, my iPhone 12 mini charges up fully while connected to the car's USB port for CarPlay in my 2019 Impreza Sport using a USB-to-Lightning cable, no hub required.
 

·
Registered
Joined
·
38 Posts
FWIW, my iPhone 12 mini charges up fully while connected to the car's USB port for CarPlay in my 2019 Impreza Sport using a USB-to-Lightning cable, no hub required.
Interesting, curious if CarPlay just uses less power or if they updated the port at some point. Does your iPhone quick charge when you plug it in, or just standard slow charge?

It's a pretty common problem across most manufactures and headunits, not just the Impreza or Subarus. The port only supplies 1 amp of power so it does a slow charge, and atleast with AA it tends to use more than that, at best my phone in particular will stay at the same battery level, though more often than not it loses charge. Might be some androids that don't have that problem. All the cables I've tried can quick charge and fast charge just fine.

Either way, still handy to have a hub for multiple devices. Can even use a USB drive for music along with AA at the same time, so the music keeps playing after the phone is unplugged and right when you get in the car, though that does occasionally make AA glitch out.
 

·
Registered
2022 Sport 5-Door
Joined
·
41 Posts
Interesting, curious if CarPlay just uses less power or if they updated the port at some point. Does your iPhone quick charge when you plug it in, or just standard slow charge?

It's a pretty common problem across most manufactures and headunits, not just the Impreza or Subarus. The port only supplies 1 amp of power so it does a slow charge, and atleast with AA it tends to use more than that, at best my phone in particular will stay at the same battery level, though more often than not it loses charge. Might be some androids that don't have that problem. All the cables I've tried can quick charge and fast charge just fine.

Either way, still handy to have a hub for multiple devices. Can even use a USB drive for music along with AA at the same time, so the music keeps playing after the phone is unplugged and right when you get in the car, though that does occasionally make AA glitch out.
While I can't speak for Android Auto just yet, I switched to a Pixel 6 from an iPhone 6s while my Impreza is at the dealer for a rear bumper.

The CarPlay port did appear to supply the required amperage. I'm unsure as to what the spec is for the port, but there is also a 2.1a port in the center console for charging devices, which historically I've used to charge an iPad.

I typically use CDs for physical media with music for my car really only needing the navigation that CarPlay provided. That and Podcasts.
 

·
Registered
Joined
·
38 Posts
While I can't speak for Android Auto just yet, I switched to a Pixel 6 from an iPhone 6s while my Impreza is at the dealer for a rear bumper.

The CarPlay port did appear to supply the required amperage. I'm unsure as to what the spec is for the port, but there is also a 2.1a port in the center console for charging devices, which historically I've used to charge an iPad.

I typically use CDs for physical media with music for my car really only needing the navigation that CarPlay provided. That and Podcasts.
Don't have the center console port on my '17, just the one in the armrest storage, and that one only supplies 1 amp, which slow charges even without AA connected. I know for sure there were updates on the newer facelift models, but curious if the '18/'19 got any improvements.
 

·
Registered
Joined
·
568 Posts
FWIW, I have a Google Pixel, and I always drive using Waze and a music app. When I was commuting 25 mins each way to work, the juice just from the car connection alone was enough to charge the battery to 100% even when not plugged in overnight. I wouldn't have space to fit anything as clunky as that Anker charger; where do you put it? Duct-tape it to the glovebox lid??? That things looks too big even for my desk!
 

·
Registered
Joined
·
38 Posts
FWIW, I have a Google Pixel, and I always drive using Waze and a music app. When I was commuting 25 mins each way to work, the juice just from the car connection alone was enough to charge the battery to 100% even when not plugged in overnight. I wouldn't have space to fit anything as clunky as that Anker charger; where do you put it? Duct-tape it to the glovebox lid??? That things looks too big even for my desk!
Guess it's just certain Androids with that issue, seen a lot of complaint for that issue with many other cars and even aftermarket headunits. Actually came across the powered data hub solution from another model of Subaru. Almost gave up on AA because of it, but works perfectly now with the hub.

Actually got a no name version, but it's almost the same exact size, and has a QC 3.0 port that doesn't pass through data if I don't want AA to kick on. Fits neatly at the bottom of the armrest storage flat, was a pretty tight fit with the USB cable it came with, but got a right angle USB type b connector for it and has plenty of space now. I bought an upper tray for that compartment, so it hides away nicely with lots of extra storage space to spare underneath. Got extra cables running up to the tray for anyone who needs a charge even while using AA.
 

·
Registered
2022 Sport 5-Door
Joined
·
41 Posts
Guess it's just certain Androids with that issue, seen a lot of complaint for that issue with many other cars and even aftermarket headunits. Actually came across the powered data hub solution from another model of Subaru. Almost gave up on AA because of it, but works perfectly now with the hub.

Actually got a no name version, but it's almost the same exact size, and has a QC 3.0 port that doesn't pass through data if I don't want AA to kick on. Fits neatly at the bottom of the armrest storage flat, was a pretty tight fit with the USB cable it came with, but got a right angle USB type b connector for it and has plenty of space now. I bought an upper tray for that compartment, so it hides away nicely with lots of extra storage space to spare underneath. Got extra cables running up to the tray for anyone who needs a charge even while using AA.
Even though I don't need it in my car, that sounds like a brilliant method you got hooked up.
Presently, my center console has been filled wit CDs since I don't have any other space big enough to store the disks so compactly.
Which Android device do you have? It may be the cable you use that is impeding the charge rate if it has some lower quality insulation and conductors with it.
 

·
Registered
Joined
·
38 Posts
Even though I don't need it in my car, that sounds like a brilliant method you got hooked up.
Presently, my center console has been filled wit CDs since I don't have any other space big enough to store the disks so compactly.
Which Android device do you have? It may be the cable you use that is impeding the charge rate if it has some lower quality insulation and conductors with it.
I have a Galaxy S8, tried a handful of different cables already, they all charge fine with any other 2a USB port or even QC 3.0 port, it's only the port in the car that gives a slow charge, even if I leave the phone off and AA never connects. One of the cables I tried doesn't even have the data lines and can do QC 3.0 just fine, but still does slow charge from the car.

Might just be the fact that I have the 6.5" base headunit, maybe the 8" ones have a proper 2a port, no CD player either so aside from AA only other option is USB or radio, otherwise I would have settled with CDs, especially with how many I have laying around from previous cars.

Been considering swapping in an 8" unit or somthing aftermarket, but have other priorities for the car ATM. And if I want to go the aftermarket route need to swap in a color display gauge cluster too so I can retain the vehicle settings that are on the headunit.
 
1 - 10 of 10 Posts
Top