5th Gen Subaru Impreza Forum banner
41 - 52 of 52 Posts

·
Registered
19 Sport Hatch MT
Joined
·
84 Posts
Thanks for the update. Looking forward to being rid of this issue.
 

·
Registered
19 Sport Hatch MT
Joined
·
84 Posts
Well SOA finally got back to me via email saying the dealer was right about not taking care of it under warranty (just passed 36k mi), but they were going to give me a $150 Parts and Service coupon to go towards the ECM update.
 

·
Registered
Joined
·
180 Posts
Well SOA finally got back to me via email saying the dealer was right about not taking care of it under warranty (just passed 36k mi), but they were going to give me a $150 Parts and Service coupon to go towards the ECM update.
So does that mean that because you are just outside of warranty they were ok to charge you or that even if you were under the factory warranty they would still charge you?
 

·
Registered
19 Sport Hatch MT
Joined
·
84 Posts
SOA response “Typically, the ECM programming would be covered under the factory warranty of 3 years or 36,000 miles and being you are beyond that this would not be a matter for warranty. Although there is a Technical Service bulletin, it is simply a guideline for the repair process of the ECM. This is not a warranty extension or guarantee that the repairs will be covered.”
 

·
Registered
2.0i 5D 5MT Silver
Joined
·
70 Posts
Called my dealer just out of curiosity and they quoted me $168 for a diagnostic another $160 to flash it?? That's absurd... Wish Subaru would just release the files so I could flash it on myself.
 

·
Registered
19 Sport Hatch MT
Joined
·
84 Posts
What the f? diagnostic for what? My dealer is charging me 1/2 hour for labor cause it's a damn flash. They're also the ones that told me to contact SOA to see if they would give me a service voucher lol
 

·
Registered
2.0i 5D 5MT Silver
Joined
·
70 Posts
Yeah absolutely absurd. Not pleased. I even pushed the guy but he wouldn't budge. I may ask another dealer.
 
  • Like
Reactions: efzed09

·
Registered
19 Sport Hatch MT
Joined
·
84 Posts
Got the tsb done this past Saturday. Put 300 miles since then and feels like it pulls more consistently now but still evaluating. Gonna be driving another few hundred miles today in Texas heat so let’s see.
 

·
Registered
2.0i 5D 5MT Silver
Joined
·
70 Posts
They should have just made it a recall.
 

·
Registered
19 Sport Hatch MT
Joined
·
84 Posts
I wish they made it a recall. Why create a new ECU update if they don't consider it an issue?

So I put another 300 miles on it yesterday. Engine definitely feels more consistent. It's not going to blow your mind, but anything helps.
 

·
Registered
2.0i 5D 5MT Silver
Joined
·
70 Posts
Yeah agreed.

I've been logging my engine and I do not see much knock correction even with my custom tune. So I think mine is alright.

Best of luck though, hope yours resolve.
 
41 - 52 of 52 Posts
Top