5th Gen Subaru Impreza Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
We just drove our new Limited 5-door home (!yay)
However, the first time we took it back out though the screen froze on the backup camera - and it's stuck there.

We've tried turning off the car and locking everything a couple times, took it for a drive, and it's still frozen on the same backup image and touchscreen controls not responding.


Any thoughts? obviously we'll call the dealer in the morning , but this seems like it should be simple right?


a little .. um. unsettling, but it's obviously one of the first off the line.
 

·
Registered
Joined
·
22 Posts
Wow...sorry to hear that ! Hopefully it is a simple fix. Keep us posted !! Yep, I'm a little concerned buying a new model year myself, but I have done it several times before and never had any problems. Enjoy your new ride......mine is due in February.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Looks like the system rebooted overnight and works again (so far)
crossing fingers it's not an ongoing problem-

Anyone know if there's a setting to keep the radio from automatically turning on everytime you start the car?
 

·
Registered
Joined
·
308 Posts
I think you may have to turn the radio off before turning the vehicle off and it'll stay off until you turn it back on individually ? That sounded kinda confusing, I hope my point got across lol.

Nonetheless, I would let the dealership know what happened just so they have it on file in case you do need to take it back.
 

·
Registered
Joined
·
33 Posts
Hey Capital, looks like we both had a similar problem, except mine was frozen on the "Safety Instruction" screen. I just posted up in the "Electronics, Audio, and Lighting" section. Look for a post called "8" with Navi frozen screen issue"
 

·
Registered
Joined
·
33 Posts
Looks like the system rebooted overnight and works again (so far)
crossing fingers it's not an ongoing problem-

Anyone know if there's a setting to keep the radio from automatically turning on everytime you start the car?
This radio thing is also bothering me! Not only that, but mine switches from CarPlay to radio when I turn off the car. I turn the car off, take the key out of ignition, the radio comes on and stays on until I open the door. It's super annoying.

I saw elsewhere on this forum that pressing the power button only mutes the deck, that you can turn off the deck by holding the power button down for 5 seconds. I don't know if that's the solution though—not sure that I want to stay in the car pushing down the radio button for 5 seconds (as nice as sitting in the new car is)...
 

·
Registered
Joined
·
12 Posts
I've had the same issue since I bought my Subaru Impreza Sport on Jan 5.
*Jan. 11 my car had a completely black screen. No radio, no display lights. The icons -- phone, media, apps -- were lit but nothing else.
*Jan.13 dealer took care and reset monitor. Said it was a fuse and couldn't recreate issue.
*Jan 16 Starlight ? system engaged itself and wouldn't allow radio or phone play until call was completed. except I never engaged the system, it did it on its own.
*Jan. 17 in am Starlight system reset itself, radio and monitor working
*Jan 17 in pm -- no radio, monitor or Starlight system
*Jan 18 -- went to start car (after calling dealer) -- battery dead but radio and monitor back. Unable to start car or shut down ignition. Had car towed to dealer after jumping the battery to get it on a flat bed. Now driving a loaner until car fixed.

It sounds like there is something really wrong with the computer electrical systems. I'm more than a little annoyed as my last Subaru (2005 impreza wagon) blew its engine a week before Thanksgiving because all the oil was gone between oil changes of 3,000 miles. Now I have two non-working Subarus in my name. I have no hope that this will get figured out soon. Sounds too complicated for that to happen.
 

·
Registered
Joined
·
8 Posts
Life long owner of many Subi. For many years Subaru has had problems with there Nav/stereo systems. Even the McIntosh stereos in the 2000-2004 Outback Limited models had problems.
Research the mass problem Subaru owners had with the '15+ Outback infotainment/nav systems. It is said that a minimum of 40% of the head units were/are defective. I purchased a '15 Outback premium when they first came out. In the 6 months of ownership (before trading it in for another brand of vehicle) I had three (3) stereo/nav head units replaced amongst other fit and finish problems and issues, the notorius wind noise issue, sticking gas cap, etc. Subaru had ZERO fix or explaination for the head units and just kept replaceing them. They played dumb and wouldn't admit to it becoming a mass problem. More and more the forums were filling with people reporting their issues with the head units... amongst the other problems.

I am interested in the new '17 Impreza sport, so I went to the local Subaru service department and asked specifically about the head units. They acknowledged the huge problem with the '15+ Outback head units and said they are made by a different manufacturer now. As people are starting to report problems with these, I'm beginning to doubt it.
I got to test drive one and sit in it and play with the sound system head unit. Just in the 30 mins I had with it, I experienced some glitchiness. Unresponsiveness to touch, Pandora playing with no sound, etc.

I only reason I don't suggest people to wait on purchasing one is only because interest rates are most likely going to skyrocket very soon here.
Otherwise I would say wait another year so Subaru can work out their bugs... unless you want to be in the dealer regularly like I was and losing work and money to deal with the car.
 

·
Registered
Joined
·
11 Posts
Hi - your last issue with battery dead but screen back on sounds like what happened with my brand new Ltd - I just posted a thread on it.
 

·
Registered
Joined
·
6 Posts
I have the 6.5 screen my premium and it too just locked up on the back up screen. Cannot change wife's radio station that is playing rap music. Very annoyed.
 

·
Registered
Joined
·
21 Posts
I've had my Impreza Premium since Jan 25th and 24 hours after getting the car I had a problem with the backup camera freezing. It froze while backing up and the screen stayed on shortly while the car was off. I left my car for about 4 hours and the stereo reset itself. Other issues I've had was my radio presets are lost. That has happened 4x since I got the car. Another issue is my phone book has been lost a few times. I have to shut off and turn back on Phone book, then it works.
The infotainment system is a computer and computers are unstable like that. I guess I should expect it.
Oh and can anybody shut off there stereo. It just seems to pause or mute the music. But, it never goes off
 

·
Registered
Joined
·
6 Posts
There's a service bulletin to fix most of the infotainment and rear backup camera issues. call your dealer. not sure if it fixes the radio on/off issue when starting/stopping the car though.
 

·
Registered
Joined
·
730 Posts
If you go to the Subaru website & at the bottom click "vehicle recalls". Enter your VIN. When I entered mine, there was a recall titled "rear view camera image failure" service campaign # WTN74. Mine was completed before I picked it up at the dealer but check yours. Maybe this recall will fix this issue.
 

·
Registered
Joined
·
5 Posts
Just had an upgrade to the head unit. They reprogrammed it. Got a call from the dealer to bring it in. Took about 30 minutes. Also, can now restart without the radio coming on. Call the dealer to see if you can have this done. It may fix your problem.
 

·
Registered
Joined
·
59 Posts
Just thinking out loud here, and really is useless info:

I was thinking about this headunit issue today, and was wondering if it had anything to do with a headunit Harman is/was trying to release since last year. I work in the Car Audio industry and we were told about this amazing new stereo that was more or less going to change the game. But.....still no release. Playing devil's advocate for a second (or even conspiracy theorist), I wonder if Harman couldn't get the CP100 right, finally kinda did, and then sold the hardware to car manufacturers, perhaps maybe just Subaru. I wonder if they're shady enough to sell a stereo that wasn't ready by their standards, but "meh" by others.

curious...

JBL Legend CP100 | Touch Screen In-Dash Receiver
 

·
Registered
Joined
·
7 Posts
Got a new Impreza Limited Friday. Yesterday, while using the GPS, the screen froze in Navigation, blocking the dashboard screen with the last direction. When I got home and turned the car off and on it worked again. Pretty bad.
 

·
Registered
Joined
·
26 Posts
We've tried turning off the car and locking everything a couple times, took it for a drive, and it's still frozen on the same backup image and touchscreen controls not responding.
If this happens again, you have to turn off the car and step away from it (so your key fob isn't within proximity) and wait at least 3-5 minutes, I would say wait till 5 minutes. That allows the car's headunit to fully shut off and restart. Anything prior will just resume where you were.

Definitely make sure you get the update done to your headunit. These issues are known and have been addressed by Subaru already.
 
1 - 20 of 24 Posts
Top