5th Gen Subaru Impreza Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter #1
Just put on a new maps update: Rel_A2.20.40.20 NAFTA.

This did not come in over the wifi connection.
 

·
Registered
Joined
·
83 Posts
I got an email the same is available for my 2018 Legacy. I downloaded and put on flash but haven't installed yet.
 

·
Registered
Joined
·
90 Posts
Discussion Starter #3
I got an email the same is available for my 2018 Legacy. I downloaded and put on flash but haven't installed yet.
I wonder if this is the same update for my wife's 2019 Crossover.

It would sure be sweet if I could use the same memory stick to update her head unit.
 

·
Registered
Joined
·
7 Posts
I just installed the new map update on 20 Nov on my 2017 Impreza. Got to work this morning and car said my Fob battery is low (Just put in a new battery in the Fob last month) Got out of car and tried locking by touching the handle and dash said to remove Fob from car and would not lock by touching the handle. I am thinking this latest update has some glitches. Did anyone else have problems with the update?
 

·
Registered
Joined
·
83 Posts
I just installed the new map update on 20 Nov on my 2017 Impreza. Got to work this morning and car said my Fob battery is low (Just put in a new battery in the Fob last month) Got out of car and tried locking by touching the handle and dash said to remove Fob from car and would not lock by touching the handle. I am thinking this latest update has some glitches. Did anyone else have problems with the update?
I am not sure if one has to do with the other but I am no expert. I just installed this update in my Legacy. My wife has been driving that car and had the same issue you had with the battery being low but before I installed the update. She said it happened a few times but it isn't consistent. I just installed the update yesterday so we will see.
 

·
Registered
Joined
·
7 Posts
Solved, wife drove the car night before last, dropped her keys between the seats. Fob battery is 3 years old and a cold night in the garage. All is well now!
 

·
Registered
Joined
·
3 Posts
I installed this update, but the next time I started the car (2018 limited) the system froze at the boot screen. Was completely unresposive - would not even turn off. Shutoff car - same thing. Was traveling and not a a familiar place with no cell coverage and thinking this sucks. Had USB update with me, so considering reinstalling, but 1st I tried using the MySubaru app. It was not even paired on Bluetooth, but noticed there was an option to "Clear STARLINK application data" and I click on that. The system immediately booted up. This feature "Resolves unstable connection with in Vehicle Navigation". Not sure why this worked, but it did and have not had an issue since.
 
1 - 8 of 8 Posts
Top