5th Gen Subaru Impreza Forum banner

81 - 98 of 98 Posts

·
Registered
Joined
·
186 Posts
anyone know if a 86201FL67A headunit works in a 2017? I know i read to stay away from the 63, but I found a 67 shipped for 300, also found a 72 out of 2019's
 

·
Registered
Joined
·
186 Posts
I bought and installed the 67a model 8" radio, 243 shipped to the door after taxes out of a 2019 with 1200 miles. I haven't tried the USB or cd player, everything works as it should though. Just in case anyone wondered if it would work in a 2017.
 

·
Registered
2019 Impreza 5 dr. Island Blue Pearl Limited
Joined
·
123 Posts
Good to know! Glad to hear that it all worked out nicely for you. Was there anything involved beyond removing the 6.5" and bolting in the new 8"?
 

·
Registered
Joined
·
186 Posts
Good to know! Glad to hear that it all worked out nicely for you. Was there anything involved beyond removing the 6.5" and bolting in the new 8"?
Only switching the brackets from one unit to the other because the new one didn't come with them, SiriusXM doesn't work because of the antenna, however a friend said his he had to order another pc for, he says he has a extra and once I know what it is or if it works I will update. As yet everything is working great and as simple as remove one unit install the other.
 

·
Registered
Joined
·
4 Posts
Only switching the brackets from one unit to the other because the new one didn't come with them, SiriusXM doesn't work because of the antenna, however a friend said his he had to order another pc for, he says he has a extra and once I know what it is or if it works I will update. As yet everything is working great and as simple as remove one unit install the other.
Any update on usb functionality, specifically carplay?
 

·
Registered
Joined
·
4 Posts
So I couldn't do WiFi updating, it just didn't work. That's why I went to the dealer. I also got my recall done. They updated my firmware and it did but it NOT fix Apple car play. But they were not fazed by me having a different screen in my '18 Crosstrek Premium. So I'll go again when I have some more free time and tell them my USB port doesn't work. I read that some people got it fixed no problem (and they didn't do a screen swap they just had the issue).
Alright, so it's been some time since I made an update. I recently went to my dealer to get my USB/Apple Carplay fixed. They told me they needed to get a new USB Port, and it's gonna take some time to get it in stock. The next time I come in they said the USB was still not working and told me they needed to order a new wiring harness (they were not clear on what it was). This was all done under warranty so no payment at all.



The original problems were the power and data were intermittent, it would disconnect and connect every 2 seconds. So no charging or data pass-through. That meant no Apple Carplay, after they installed everything, Apple Carplay still DOES NOT work. My phone doesn't even detect a car, pre-fix it would detect my car but like I said the connection was intermittent so after 2 secs it wasn't stable enough for carplay. Post fix, I can plug in my phone and use Subaru's own Media interface to stream music and charge my phone. It's kinda annoying that the dealer didn't connect an iphone to test it. I tested with 3 different iPhones (5s, 6s and Xs) with 3 different iOS versions. None of them worked. Tried different cables, nope. I plan on going tomorrow again and I'll update soon.
 

·
Registered
Joined
·
35 Posts
I finally put one of the 8 inch head units in my imp.The car play didn't work at first. It had to have the software updated. My dealer (Thelen subaru bay city Mi) charged !00 dollars to do that. I tried car play again and it said I needed the starlink app. I got that and now car play works fine.And I have a new reason to hate my dealer.
 

·
Registered
Joined
·
5 Posts
I finally put one of the 8 inch head units in my imp.The car play didn't work at first. It had to have the software updated. My dealer (Thelen subaru bay city Mi) charged !00 dollars to do that. I tried car play again and it said I needed the starlink app. I got that and now car play works fine.And I have a new reason to hate my dealer.
Glad to hear at least you were able to get it working and they were able to update it for you even if the normal over the air update wasn't working for you. The 8" head units are supposed to be able to manually request an update if you connect it to a WiFi network but with how buggy everything else on these radios is I'm not surprised the built in update feature wasn't working.

As an aside should you or anyone else find yourself in this situation again where the dealer wants some large pile of money just to plug a USB stick with the update file into your radio you should know that assuming you feel its worth your time and within your skill set you can find all the current update files for the various radios on Subaru's own STIS (Subaru Technical Information System) website for your car which subaru only charges $35 for 72 hours of access. Just make sure to use the correct update file for YOUR radio as trying to install an update for the wrong radio will likely lead to terrible things :unsure::LOL: and is probably why they don't make the update files more publicly available in the first place (going with that over pure greed). It would not surprise me at all if Harman Kardon did not implement proper checks to make sure updates were applicable to the radio you are attempting to update. STIS has the updates for all sizes of radios including the tiny 6.5 radios as well if anyone is wondering.

Alright, so it's been some time since I made an update. I recently went to my dealer to get my USB/Apple Carplay fixed. They told me they needed to get a new USB Port, and it's gonna take some time to get it in stock. The next time I come in they said the USB was still not working and told me they needed to order a new wiring harness (they were not clear on what it was). This was all done under warranty so no payment at all.

The original problems were the power and data were intermittent, it would disconnect and connect every 2 seconds. So no charging or data pass-through. That meant no Apple Carplay, after they installed everything, Apple Carplay still DOES NOT work. My phone doesn't even detect a car, pre-fix it would detect my car but like I said the connection was intermittent so after 2 secs it wasn't stable enough for carplay. Post fix, I can plug in my phone and use Subaru's own Media interface to stream music and charge my phone. It's kinda annoying that the dealer didn't connect an iphone to test it. I tested with 3 different iPhones (5s, 6s and Xs) with 3 different iOS versions. None of them worked. Tried different cables, nope. I plan on going tomorrow again and I'll update soon.
I'm curious what the resolution was to this. Did they install a new USB aux port, likely part 86257FL00B?
 

·
Registered
Joined
·
35 Posts
Glad to hear at least you were able to get it working and they were able to update it for you even if the normal over the air update wasn't working for you. The 8" head units are supposed to be able to manually request an update if you connect it to a WiFi network but with how buggy everything else on these radios is I'm not surprised the built in update feature wasn't working.

As an aside should you or anyone else find yourself in this situation again where the dealer wants some large pile of money just to plug a USB stick with the update file into your radio you should know that assuming you feel its worth your time and within your skill set you can find all the current update files for the various radios on Subaru's own STIS (Subaru Technical Information System) website for your car which subaru only charges $35 for 72 hours of access. Just make sure to use the correct update file for YOUR radio as trying to install an update for the wrong radio will likely lead to terrible things :unsure::LOL: and is probably why they don't make the update files more publicly available in the first place (going with that over pure greed). It would not surprise me at all if Harman Kardon did not implement proper checks to make sure updates were applicable to the radio you are attempting to update. STIS has the updates for all sizes of radios including the tiny 6.5 radios as well if anyone is wondering.


I'm curious what the resolution was to this. Did they install a new USB aux port, likely part 86257FL00B?
I appreciate the info about STIS didn't know about it.
 

·
Registered
Joined
·
3 Posts
Sorry to revive a dead thread, I’ve been reading up on these swaps for a while and this collection was super influential in me making the choice to try it so I thought I’d ask here. I have a 2017 premium. I found what turned out to be a 86201FL62A (there was a picture but not too much info) through a junkyard online and only paid about $100 shipped, which I thought was awesome and with the risk of it being a different unit. The unit arrived and I installed yesterday only to find myself in the scenario of CarPlay not working, everything else seems to be perfect, functionality wise. My phone connects just long enough to read the prompt asking for my approval to allow access when the phone is locked and it disappears. It never seems to fully connect or allow any features to be used. I’m wondering if the unit might be too new as has built in wifi which I have found doesn’t seem to be an option until 2018. I used the Wifi to update to the latest software (which in and of itself was kind of a pain) but even after the update I’m having the same issue. Anybody have any suggestions?
 

·
Registered
Joined
·
35 Posts
Sorry to revive a dead thread, I’ve been reading up on these swaps for a while and this collection was super influential in me making the choice to try it so I thought I’d ask here. I have a 2017 premium. I found what turned out to be a 86201FL62A (there was a picture but not too much info) through a junkyard online and only paid about $100 shipped, which I thought was awesome and with the risk of it being a different unit. The unit arrived and I installed yesterday only to find myself in the scenario of CarPlay not working, everything else seems to be perfect, functionality wise. My phone connects just long enough to read the prompt asking for my approval to allow access when the phone is locked and it disappears. It never seems to fully connect or allow any features to be used. I’m wondering if the unit might be too new as has built in wifi which I have found doesn’t seem to be an option until 2018. I used the Wifi to update to the latest software (which in and of itself was kind of a pain) but even after the update I’m having the same issue. Anybody have any suggestions?
I had the same problem.I got mine to work by installing the starlink app and the aha radio app on my phone. Not sure which one made it work but it has been fine since.
 

·
Registered
Joined
·
5 Posts
I had the same problem.I got mine to work by installing the starlink app and the aha radio app on my phone. Not sure which one made it work but it has been fine since.
If this works for you @TMW550 please come back and post a follow up because I had the exact same issue. I ended up just putting my old radio back in since a radio that didn’t connect to my phone was worse than the original with a tiny screen. If it can be fixed by just installing an app that would be great!
I was afraid I’d have to replace the USB cable that runs from the radio to the center arm rest console with one that comes in cars equipped with the larger radio but didn’t want to sink the additional money without knowing for sure the usb cable would fix it.
 

·
Registered
Joined
·
3 Posts
@oldsplicer @HypervisorX Thanks for the replies! No luck with the app install. I actually already had it and it wasn’t working but I tried uninstalling and re installing the app and still no dice. The annoying part is that I had an old android lying around and I have that I try and it seemed to work with Android auto, the phone itself said it was too old to run the newest android auto but it was a steady connection, no flashing messages or power disconnection.

I was thinking the same about it probably needing the newer usb cable but it not being worth the hassle. It’s too bad because I love the bigger unit but not enough to sacrifice CarPlay even on a smaller screen. Back to the original unit I go!
 

·
Registered
Joined
·
3 Posts
I was so close to giving up and I wanted to keep trying just a little more. Does anyone who this swap has worked for remember which of these three plugs they used? I know the cord should only fit into one, but I’m wondering if there is a difference in usb plugs between our vehicles. My original cable fits the far left and I have a single usb/aux in my center console. I’ve seen a picture like this on here before but didn’t see a definitive answer.
Thanks!!
25137
 

·
Registered
Joined
·
380 Posts
Discussion Starter · #98 ·
I was so close to giving up and I wanted to keep trying just a little more. Does anyone who this swap has worked for remember which of these three plugs they used? I know the cord should only fit into one, but I’m wondering if there is a difference in usb plugs between our vehicles. My original cable fits the far left and I have a single usb/aux in my center console. I’ve seen a picture like this on here before but didn’t see a definitive answer.
Thanks!! View attachment 25137
I installed the 86201FL62A successfully in my 2017 impreza premium a couple years ago. I forgot how the wiring looked, but my Android Auto works fine. I never tried Apple Carplay.
 
81 - 98 of 98 Posts
Top