5th Gen Subaru Impreza Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
232 Posts
Discussion Starter #1
To whom it may concern:

Multiple times now I've had to deal with some kind of "popup" taking over my Mac while on impreza5.com. The only recourse is to close out the tab, history, Safari, , and reboot. The Mac takes care of the rest, thankfully. It's some kind of arm-twisting, impossible to get out of, demand for a link to be clicked to get rid of virus' on my computer. I have none and it's usually a MacKeeper POS if history is correct.

As such I now consider this website a place to stay away from, and only quickly check before another hook occurs. Shame. It is either going to be addressed or I'm, as they say... outa here.

Too bad, but I also don't like the way the site's numerous ads gradually inflates the memory footprint, consumeing an inordinate amount of memory... which at some point after a lot of new posts to read or I forget, forces me to terminate the page. This ruins my interest in browsing the forum. Though the format in general is the same as other websites I regularly visit, they have no similar problems.

I put up with the memory issues and the atrocious data vs ad ratio and the lack of any personality to this website format ... but I won't put up with the continuing "virus" problem. Hopefully things change and the site prospers. But right now it does more for advertisers than it does for me, the membership.
 

·
Registered
Joined
·
282 Posts
You could take matters into your own hands and add a network redirect. In this way, the ads will simply not find their source-server.
 

·
Super Moderator
Joined
·
1,645 Posts
Very strange, I am on pretty much the cheapest netbook you can buy and have never had this site cause any problems with my computer.
 

·
Registered
Joined
·
232 Posts
Discussion Starter #6
It hasn't happened in a few days... pretty much since I posted the thread. But for a week or two before that every time I got on it happened. Could have been coincidence, and not related to Imp5. Good for now, and the feedback helps, Thanks.
 

·
Registered
Joined
·
232 Posts
Discussion Starter #8 (Edited)
May be Safari... also may be why Safari has had more than one upgrade these past couple weeks. Wife uses Firefox, she never has issues. Time for me to try it.

The most rewarding thing to me is... it isn't the website. I'd rather it be on my end, I can deal with that. Had my Win 10 machine lose bootmgr this morning... fixed, but if it isn't one computer thing it's another. Normal, and OK. Losing faith in where I browse, however, is somehow a bigger issue for me.

Thanks, people, I consider the issue resolved... as a non-issue and a thread I'd delete were that an option. Oh, well....
 
1 - 11 of 11 Posts
Top