5th Gen Subaru Impreza Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Picked up my new Impreza on 2/4/17. Programmed everything and when I came out to drive it the next day, my radio presets were wiped out, my Sirius/XM radio had reverted to a trial period, my bluetooth no longer worked. I also received a warning on my Starlink app that there was a fault in the system. Upon calling the dealership I was informed by a service adviser that she owns the same exact car and she had all these issues and more for the two months since she purchased her car. Screen going blank, radio issues, back up camera fail, clock resetting, etc. She said that she had been told maybe a fix would be in by May. We went nuts! A lot has happened since but all indications are that Subaru has been aware of this issue for quite some time and has not put a stop sell order on the vehicles. We have requested a repurchase of our car, contacted automotive agencies to investigate and have contacted the Department of Justice in our state to file a formal complaint. We are not accepting this situation. This is fraud.
 

·
Registered
Joined
·
308 Posts
As you can probably tell, a lot of owners on here are experiencing similar issues which is horrendous. I understand having a few faults come up but all of this and they knew about it ?! That's pretty unacceptable.
 

·
Registered
Joined
·
25 Posts
what's strange is that not all seem to have issues. It would seem if they are working on a "fix" all Sport and Limited models would have the same problems. Knock on wood, so far mine has been ok. At least it sounds like they are agreeing that there are issues and hopefully there is a fix. We had the same problems with our Infiniti Q50 when it first came out and I felt the same way and eventually they exchanged the car for us, but it still seems like companies are rushing the new models out without enough pre-testing. 3 model years later the bugs have been worked out on the Q50's, but Infiniti has lost a lot of loyal customers.
 

·
Registered
Joined
·
157 Posts
I had most of the issues posted here, except the back up camera and draining battery.

I had lagging touch screen, locked screen, etc.

I tried the fuse pull, battery disconnect, etc. But nothing worked as well as doing the below (Note: this will erase your presets and all infotainment settings, as well as possibly erase your sirrius/xm subscription, requiring a flash be sent out again):

1) Push and hold the left most control dial until you enter the menus.

2) Look to the bottom left of your screen and select "General"

3) Scroll down until you see "Factory Data Reset" push, and agree to reset.

4) It will take a few minutes to reset, but if your system is like mine, it will suddenly have fluid and non jamming selections, icon moving, etc.

The only thing that still acts up, and very intermittently, is a dropping of the Apple CarPlay function.

Just a heads up. Try it, but remember, you'll lose your presets, sound settings, bluetooth phone registration, etc.

Note: I own a 2017 Sport with the 8" infotainment, car delivered (was ordered) Feb 9.
 

·
Registered
Joined
·
20 Posts
4 day old car, seeing similar issues already...

Day One, locked screen, (fixed by disconnecting / reconnecting battery) Day 4 NO AUDIO! No fix as of yet.:crying:
 

·
Registered
Joined
·
20 Posts
Dealerships now getting a "fix"- a "REFLASH", they are scheduling 40 minutes blocks to make the fix, mine is scheduled for Thursday the 2nd...I'll report back how it went.....the dealership said they are "reflashing" all new cars on their lot, and anyone who needs it done that already owns one.....
 

·
Registered
Joined
·
26 Posts
I had most of the issues posted here, except the back up camera and draining battery.

I had lagging touch screen, locked screen, etc.

I tried the fuse pull, battery disconnect, etc. But nothing worked as well as doing the below (Note: this will erase your presets and all infotainment settings, as well as possibly erase your sirrius/xm subscription, requiring a flash be sent out again):

1) Push and hold the left most control dial until you enter the menus.

2) Look to the bottom left of your screen and select "General"

3) Scroll down until you see "Factory Data Reset" push, and agree to reset.

4) It will take a few minutes to reset, but if your system is like mine, it will suddenly have fluid and non jamming selections, icon moving, etc.

The only thing that still acts up, and very intermittently, is a dropping of the Apple CarPlay function.

Just a heads up. Try it, but remember, you'll lose your presets, sound settings, bluetooth phone registration, etc.

Note: I own a 2017 Sport with the 8" infotainment, car delivered (was ordered) Feb 9.
I did the same thing. My infotainment was having odd lockups and not recognizing my phone while plugged in with CarPlay and after doing a reset like this, most issues have dissapeared. I'll still take advantage of that software update due to the recall they issued (WTN74)
 
1 - 8 of 8 Posts
Top