5th Gen Subaru Impreza Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
3 Posts
I have also had the same issue, dealer ordered the new part two weeks ago. They did not say anything about it being related to the remote start install though.
 

·
Registered
Joined
·
730 Posts
I wonder what's gonna happen in summer when it's 100F outside these vents will be popping off like there's no tomorrow. Do all the Impreza's have that shabby adhesive strip or just the ones that got the remote start installed?
 

·
Registered
Joined
·
65 Posts
i had this same problem, they've already replaced mine and its been good to go.

I believe they told me a clip was broken.
 

·
Registered
Joined
·
9 Posts
i had the issue as well. Took several trips to the dealer to be fixed. They said it was a clip not holding properly
 

·
Registered
Joined
·
231 Posts
My sport has not had this issue, and it has black paint and interior..100+ degree days in a parking lot for 8 hours and its fine. The interior gets to like 130 degrees but nothing is coming off. Hopefully it is just a limited batch that is coming off..
 

·
Registered
Joined
·
320 Posts
Seriously wtf, if this crap happens to my car I am going to flip out. I have never seen so many problems with a new Subaru in my whole life.
First gens of a new platform always have teething problems unfortunately. Sometimes its worse than others. The good thing is so far there seem to be no major mechanical weaknesses with the platform or drivetrain.
 

·
Registered
Joined
·
1,187 Posts
If you?re not prepared for teething pain as was mentioned above, then don?t buy a first year model...ever. They all have it regardless of manufacturer. I was prepared for minor issues which most have all been. I have had zero issues with my car and had all software updates performed prior to making my purchase. Vents are an annoyance that can be easily fixed as are the other first year issues. The body and drive train is solid!
 

·
Registered
Joined
·
3 Posts
My 2018 did this. They claimed they couldn't "recreate the issue" and said the vent fit in perfectly fine, so i drove it back around and the vent popped back out. They looked again and said it's just sitting in there and there are no clips. I responded with "yes there are, because there is one that broke off and is sitting on my floor mat.
 

·
Registered
Joined
·
1 Posts
It's most likely a broken clip. Had the same problem the same day I picked mine up (May 5th). Went back to the dealership the day of and waited 30 mins for them to put in a new one. Worked for 5 mins after leaving dealership, then popped out again. Went back a week later, told a different person at the dealership and he immediately stopped me and said "I know your problem" and fixed it within 5 mins. Hasn't popped out since.
 

·
Registered
Joined
·
74 Posts
My vent was popped out when I bought the car (2018) but didn't notice it for a while. Brought it in for my first service and the dealer replaced the vent. No issues since May.
 

·
Registered
'21 Sport Hatch CVT Ocean Blue Pearl
Joined
·
17 Posts
So 5 model years into this generation and it's still happening. Just had the same issue "pop up" on my 2021. Taking it in tomorrow to get it fixed, I hope.
 

·
Registered
'21 Sport Hatch CVT Ocean Blue Pearl
Joined
·
17 Posts
Took it in. At first the mechanic "fixed it" by doing the push & stick method but of course, whatever clip that is inside is broken so by the time I got back to my car, it was back to broken. Part was ordered and within a week I had it repaired by the dealer for no cost.

Hopefully not cycling through these things but seems it's a one and done for others as well. Maybe it's sloppy install at the plant.
 
1 - 18 of 18 Posts
Top