5th Gen Subaru Impreza Forum banner

21 - 22 of 22 Posts

·
Registered
Joined
·
6 Posts
No it has not. I just got busy with work.
I have two issues: 1) the place i bought the car from is an hour from home. 2) the local dealership told me to take it to the place i bought it from despite being under warranty.
Excuses I know.

Even today while I was driving my coffee cup was shaking. Sometimes its more pronounced than other times. This weekend I drove the car and it shook like I had something in the tire. I stopped, got out, turned off the car, found nothing, but the sound went away.
Did you ever figure out the issue? I'm having the same issue, vibration past 65 mph after about 20 minutes of driving on the Hwy. Here is what I did, and still having the same issue just not as bad.

Had the tires balanced twice (No bent rims)
Rotated tires front to back, there is some uneven wear on the inside of the front tires which were rotated from the back. Running 35psi all around.
Installed new Duralast Gold rotors on under warranty via AutoZone 2 days ago. Kept the same Ceramic pads that were newly installed in March. New rotors seem way smoother, but still some pulsing/vibration when braking under high speed such as an off ramp.
Checked the suspension and everything looks good.

Going to get an alignment this weekend, test drive and see if it helps, possibly another balance.

If anybody has any recommendations please let me know, I feel like I'm going crazy worrying about this vibration.

2019 Premium Hatch, 40K Miles.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #22 ·
I'm taking it in on Friday. I'll let you know the results thereafter. I truly wonder if its the Torque vectoring, and wish I could turn it off to test it. Can I just pull the ABS fuse?
 
21 - 22 of 22 Posts
Top