5th Gen Subaru Impreza Forum banner

21 - 35 of 35 Posts

·
ModFather
2019 Subaru Impreza Sport 5 Dr. Manual Shift
Joined
·
1,131 Posts
Discussion Starter · #21 ·
What really gets me is the randomness of it all. When it doesn't work, there is nothing I can do at the time to get it to start working. Then after the car is parked and I come back say after work. It will start working like nothing happened. I know it seems like first world problems but I really rely on my maps. My son works at a car dealership and drives just about every type of vehicle. I always ask how AA works for others and there never seems to be this type of issue for him. His new car even has wireless AA and he says it works flawlessly.

Very frustrating.
 
  • Like
Reactions: longboy

·
Registered
Joined
·
113 Posts
Well, I updated the software on my '19 sport yesterday, and now AA does not open at all! This is the most aggravating software I've ever had to deal with!!!
Is there a new update or is this one you just never did?
 

·
Registered
Joined
·
407 Posts
It was an update from a month or more ago; I was just waiting for warmer temps before I did it. Today, it STARTED to load AA, but then crapped-out halfway through. Frankly, I'm getting tired of this daily game of "AA bingo", and I'm seriously considering the built-in navigation. How much do they charge for that? I believe it uses the Tom Tom system; how good are they? I'm through with trying to make Waze an AA work on this car...
 

·
Registered
Joined
·
113 Posts
I haven't had a problem recently with AA loading but since my new S21 I can't get texts to show up under AA even though it is selected. As a matter of fact it happens on both my 18 Legacy and 19 Impreza. Not sure what to do yet. So far though the Anker 180 degree cable seems to be good.
 

·
Registered
Joined
·
54 Posts
This really sounds like a cable issue. The cable may be a little loose and disconnect when you hit a bump or move the phone. This will have the stereo revert back to the Bluetooth connection for audio have AA grayed out. Can you wiggle the cable when it's connected to your phone?

At least that what was happening in my car with my Samsung S21. I replaced the cable with a new Anker cable and all is well since then. The previous Anker cable was bought a few years ago.
 

·
ModFather
2019 Subaru Impreza Sport 5 Dr. Manual Shift
Joined
·
1,131 Posts
Discussion Starter · #27 ·
I also like Anker cables (and have an S21) for me. everything works great for long stretches of time. Then for no apparent reason it will not project to the head unit's screen. When I try to get it to hook up again I will plug and unplug the cable at both ends. Later it will start working again as if nothing ever happened. For me at least it's not a cable issue I'm sure of it. I carry a few even the one that was included with the phone.
 

·
Registered
Joined
·
407 Posts
Since I last posted, I have:

Tried 3 different data-transfer cables, on both USB connectors
Cold-restarted my phone twice
Uninstalled and reinstalled Android Auto
Tried different startup scenarios (plug in before starting the car, after starting the car, etc.)

I've had problems with AA for about the last 6 months, but right after I did the new Subaru system update, it has not worked AT ALL. It's either a software problem with the car, or a hardware problem with the phone. It doesn't seem to be possible to just re-download the Subaru software (or to go back to the previous version). I'd like to try that before I replace the phone.
 

·
Registered
Joined
·
113 Posts
What is the problem with AA? Not loading? Have you googled it? I remember I had a problem with AA at some point and I had to do something in the phone settings but I can't for the life of me remember what I did. I "think" it was some power setting.
 

·
Registered
Joined
·
407 Posts
Problem fixed! After trying every USB cable I had, it was obvious to me that the micro-USB connector on my cheap old Samsung phone was shot. It was time for a replacement, anyway, so I upgraded to a Pixel 4a, and wow, does AA works well with that phone! The only problem, though, is that it uses a USB-C connector, so I had to buy new cables...
 

·
Registered
Joined
·
113 Posts
Great. Now, wanna help me with the AA txt message issue? ;-) I googled some and didn't get an answer yet. I gave up for now.
 

·
Registered
Joined
·
12 Posts
Great. Now, wanna help me with the AA txt message issue? ;-) I googled some and didn't get an answer yet. I gave up for now.
I recently reset my Bluetooth on my phone since it was causing frequent problems connecting and dropping the connection. After I did that I noticed my text messages were not coming across. The car seemed able to receive the texts but the phone wasn't allowing it. I googled the issue and found a setting I needed to change on the phone, must have changed during the bluetooth reset. I'll see if I can track it down, but in the meantime check your app settings and permissions.
 

·
Registered
Joined
·
12 Posts
Go into the Bluetooth settings, select your Subaru and turn on Show Notifications - or allow messages.
 

·
Registered
Joined
·
113 Posts
Go into the Bluetooth settings, select your Subaru and turn on Show Notifications - or allow messages.
I got this set. I get messages on the Subaru head unit just not in AA.
 

·
Registered
Joined
·
407 Posts
With the change of phone, now AA has hijacked my phone contacts. I can't dial just by pressing the phone button anymore and saying "Call Joe" like I used to; now if I want to call a contact from my phone, I have to take the phone out of my pocket, connect it to the cable, open AA, scroll to the phone app, choose contacts, and press the button on the display. What a pain! On short rides, I don't even bother connecting the phone. Yeah, I can still receive calls, and I can always dial 'Joe"s number by using voice and saying the numbers aloud, but really, what a pain!
 
21 - 35 of 35 Posts
Top